Задание 9 ЕГЭ информатика по теме «электронные таблицы»

Дата изменения: 3 сентября 2021
На уроке рассмотрен материал для подготовки к ЕГЭ по информатике, разбор 9 задания. Объясняется тема о работе в электронных таблицах и базах данных.

ЕГЭ по информатике 9 задания объяснение

9-е задание: «Электронные таблицы»
Уровень сложности — базовый,
Требуется использование специализированного программного обеспечения — да,
Максимальный балл — 1,
Примерное время выполнения — 6 минут.
  
Проверяемые элементы содержания: Умение обрабатывать числовую информацию в электронных таблицах
До ЕГЭ 2021 года — определенные типы этого задания были заданием № 7 ЕГЭ

  


Ниже рассмотрены наиболее часто встречающиеся функции и их смысл. Наводите курсор на пример для просмотра ответа.

Таблица: Наиболее часто используемые функции
русский англ. действие синтаксис
СУММ SUM Суммирует все числа в интервале ячеек СУММ(число1;число2)
Пример:
=СУММ(3; 2)
=СУММ(A2:A4)
СЧЁТ COUNT Подсчитывает количество всех непустых значений указанных ячеек СЧЁТ(значение1, [значение2],…)
Пример:
=СЧЁТ(A5:A8)
СРЗНАЧ AVERAGE Возвращает среднее значение всех непустых значений указанных ячеек СРЕДНЕЕ(число1, [число2],…)
Пример:
=СРЗНАЧ(A2:A6)
МАКС MAX Возвращает наибольшее значение из набора значений МАКС(число1;число2; …)
Пример:
=МАКС(A2:A6)
МИН MIN Возвращает наименьшее значение из набора значений МИН(число1;число2; …)
Пример:
=МИН(A2:A6)
ЕСЛИ IF Проверка условия. Функция с тремя аргументами: первый аргумент — логическое выражение; если значение первого аргумента — истина, то результатом выполнения функции является второй аргумент. Если ложно — третий аргумент. ЕСЛИ(лог_выражение;
значение_если_истина;
значение_если_ложь)
Пример:
=ЕСЛИ(A2>B2;"Превышение";"ОК")
СЧЁТЕСЛИ COUNTIF Количество непустых ячеек в указанном диапазоне, удовлетворяющих заданному условию. СЧЁТЕСЛИ(диапазон, критерий)
Пример:
=СЧЁТЕСЛИ(A2:A5;"яблоки")
СУММЕСЛИ SUMIF Сумма непустых ячеек в указанном диапазоне, удовлетворяющих заданному условию. СУММЕСЛИ
(диапазон, критерий, [диапазон_суммирования])
Пример:
=СУММЕСЛИ(B2:B25;">5")
  • следует иметь в виду, что при использовании функции СРЗНАЧ не учитываются пустые ячейки и текстовые ячейки; например, после ввода формулы в C2 появится значение 2 (не учитывается пустая А2):
  • 1

    Анализ диаграмм и графиков в электронных таблицах

    Типы ссылок в ячейках

    Формулы, записанные в ячейках таблицы, бывают относительными, абсолютными и смешанными.

    • Имена ячеек в относительной формуле автоматически меняются при переносе или копировании ячейки с формулой в другое место таблицы:
    •  Относительная адресация

      Относительная адресация:
      имя столбца вправо на 1
      номер строки вниз на 1

    • Имена ячеек в абсолютной формуле не меняются при переносе или копировании ячейки с формулой в другое место таблицы.
    • Для указания того, что не меняется столбец, ставится знак $ перед буквой столбца. Для указания того, что не меняется строка, ставится знак $ перед номером строки:
    • объяснение егэ по информатике

      Абсолютная адресация:
      имена столбцов и строк при копировании формулы остаются неизменными

    • В смешанных формулах меняется только относительная часть:
    • информатика егэ теория

      Смешанные формулы

    Построение диаграмм

    • Диаграммы используются для наглядного представления табличных данных.
    • Разные типы диаграмм используются в зависимости от необходимого эффекта визуализации.
    • Так, круговая и кольцевая диаграммы отображают соотношение находящихся в выбранном диапазоне ячеек данных к их общей сумме. Иными словами, эти типы служат для представления доли отдельных составляющих в общей сумме.
    • Соответствие секторов круговой диаграммы (если она намеренно НЕ перевернута) начинается с «севера»: верхний сектор соответствует первой ячейке диапазона.
    • круговая диаграмма, объяснение 9 задания егэ

    • Типы диаграмм Линейчатая и Гистограмма (на левом рис.), а также График и Точечная (на рис. справа) отображают абсолютные значения в выбранном диапазоне ячеек.
    • гистограмма, 9 задание егэ

    Егифка ©:

    решение 9 задания ЕГЭ

    * Некоторые изображения, представленные в изложении теоретического материала, заимствованны с сайта К. Полякова

    ЕГЭ по информатике 9 задание разбор

    Плейлист видеоразборов задания на YouTube:
    Задание демонстрационного варианта 2022 года ФИПИ


    Встроенные функции в электронных таблицах

    9 задание. Демоверсия варианта ЕГЭ по информатике 2021, ФИПИ:

    Задание выполняется с использованием прилагаемых файлов

      
    Откройте файл электронной таблицы, содержащей вещественные числа – результаты ежечасного измерения температуры воздуха на протяжении трёх месяцев.
    Найдите разность между максимальным значением температуры и её средним арифметическим значением.
    В ответе запишите только целую часть получившегося числа.

    Ответ: 14
      
    Видео 


    Задание 1: (эмулятор экзамена 2021)

    Задание выполняется с использованием прилагаемых файлов

      
    Найдите разность между максимальным и минимальным числом в диапазоне C48:Y360. В ответе запишите только целую часть числа.

    ✍ Решение:

      Добавим формулы в пустые ячейки:

    • Ячейка A502 = МАКС(C48:Y360)
    • Ячейка B502 = МИН(C48:Y360)
    • любая пустая ячейка =A502-B502
    • Оставляем только целую часть (отсекаем дробную, не округляя число).

    Ответ: 920


    Задание: (К. Поляков, задание № 3)

    Задание выполняется с использованием прилагаемых файлов

      
    Откройте файл электронной таблицы 9-0.xls (в заголовке задания), содержащей вещественные числа – результаты ежечасного измерения температуры воздуха на протяжении трёх месяцев.
    Найдите разность между максимальным значением температуры и её средним арифметическим значением в первой половине дня (до 12:00 включительно).
    В ответе запишите только целую часть получившегося числа.

    ✍ Решение:

      Добавим формулы в пустые ячейки:

    • Ячейка A94 = МАКС(B2:N92) = 35,6
    • Ячейка A95 =СРЗНАЧ(B2:N92) = 21,4
    • любая пустая ячейка =A94-A95 = 14,2
    • Оставляем только целую часть (отсекаем дробную, не округляя число).

    Ответ: 14


    Задание: (К. Поляков, задание № 15)

    Задание выполняется с использованием прилагаемых файлов

      
    Откройте файл электронной таблицы 9-0.xls (в заголовке задания), содержащей вещественные числа – результаты ежечасного измерения температуры воздуха на протяжении трёх месяцев.
    Найдите разность между максимальным значением температуры в апреле и её средним арифметическим значением во второй половине дня (с 12:00) за тот же период.
    В ответе запишите только целую часть получившегося числа.

    ✍ Решение:

      Добавим формулы в пустые ячейки. Возьмем значения ячеек только за апрель (04 месяц). Для поиска среднего арифметического значения учтем также, что время должно быть с 12.00, то есть со столбца N:

    • Ячейка A94 = МАКС(B2:Y31) = 26,0
    • Ячейка A95 = СРЗНАЧ(N2:Y31) = 21,0
    • любая пустая ячейка =A94-A95 = 5,0
    • Оставляем только целую часть (отсекаем дробную, не округляя число).

    Ответ: 5


    Задание: (задание № 10, Сколково сайт)

    Задание выполняется с использованием прилагаемых файлов

      
    Откройте файл электронной таблицы 9-0.xls (в заголовке задания), содержащей вещественные числа – результаты ежечасного измерения температуры воздуха на протяжении трёх месяцев.
    Найдите разность между максимальным и минимальным значением температуры среди измерений, сделанных в 17:00.
    В ответе запишите только целую часть получившегося числа, округлять не нужно.

    ✍ Решение:

      Добавим формулы в пустые ячейки. Возьмем значения ячеек только за 17.00, то есть со столбца S:

    • Ячейка A94 =МАКС(S2:S92) = 37,8
    • Ячейка A95 =МИН(S2:S92) = 22,4
    • любая пустая ячейка =A94-A95 = 15,4
    • Оставляем только целую часть (отсекаем дробную, не округляя число).

    Ответ: 15


    Задание: (задание № 12, Сколково сайт)

    Задание выполняется с использованием прилагаемых файлов

      
    Откройте файл электронной таблицы 9-0.xls (в заголовке задания), содержащей вещественные числа – результаты ежечасного измерения температуры воздуха на протяжении трёх месяцев.
    Посчитайте сумму средних арифметических значений температур в 16:00 и в 23:00.
    Округлите полученное число до целого и запишите его в ответ.

    ✍ Решение:

      Добавим формулы в пустые ячейки. Возьмем значения ячеек только в 16.00, то есть со столбца R и в 23.00, то есть со столбца Y:

    • Ячейка A94 =СРЗНАЧ(R2:R92) = 29,9
    • Ячейка A95 =СРЗНАЧ(Y2:Y92) = 20,8
    • любая пустая ячейка =A94+A95 = 50,7
    • После округления получаем 51.
    • Можно также решить данное задание, записав все в одну строку:
    •  = СРЗНАЧ(R2:R92)+СРЗНАЧ(Y2:Y92)

    Ответ: 51


    Задание: (задание № 15, Сколково сайт)

    Задание выполняется с использованием прилагаемых файлов

      
    Откройте файл электронной таблицы 9-0.xls (в заголовке задания), содержащей вещественные числа – результаты ежечасного измерения температуры воздуха на протяжении трёх месяцев.
    Найдите результат деления суммы всех значений температуры на максимальное значение.
    В ответе запишите только целую часть получившегося числа, округлять не нужно.

    ✍ Решение:

      Добавим формулы в пустые ячейки. Используем в формулах вcю таблицу, то есть диапазон ячеек от B2 до Y92 (B2:Y92):

    • Ячейка A94 =МАКС(B2:Y92) = 38,0
    • Ячейка A95 =СУММ(B2:Y92) = 51807,0
    • любая пустая ячейка (поделим сумму на максимальное значение) =A95/A94 = 1363,3
    • Оставляем только целую часть = 1363.

    Ответ: 1363


    Задание: (задание № 16, Сколково сайт)

    Задание выполняется с использованием прилагаемых файлов

      
    Откройте файл электронной таблицы 9-0.xls (в заголовке задания), содержащей вещественные числа – результаты ежечасного измерения температуры воздуха на протяжении трёх месяцев.
    Посчитайте чему будет равно самое часто встречаемое значение температуры и среднее арифметическое значений температуры за всё время измерений. Найдите разницу между самым встречаемым значением и средним арифметическим значением.
    В ответе запишите только целую часть числа (разницы).

    ✍ Решение:

      Добавим формулы в пустые ячейки. Используем в формулах вcю таблицу, то есть диапазон ячеек от B2 до Y92 (B2:Y92):

    • Ячейка A94 =СРЗНАЧ(B2:Y92) = 23,7
    • Ячейка A95 =МОДА(B2:Y92) = 25,7
    • Для нахождения наиболее часто встречаемого значения используется функция МОДА ()
    • любая пустая ячейка =A95-A94 = 2,0
    • Оставляем только целую часть = 2.

    Ответ: 2


    Также можно посмотреть некоторые аналогичные задания ОГЭ

    Задания прошлых лет для тренировки

    ЕГЭ по информатике задание 9 (пример задания P-00, Поляков К.)

    Задан фрагмент электронной таблицы:
    1

    Как изменится значение ячейки C3, если после ввода формул переместить содержимое ячейки B2 в B3?
    («+1» означает увеличение на 1, «-1» означает уменьшение на 1):

    Варианты:
    1) -2
    2) -1
    3) 0
    4) +1

    ✍ Решение:

      Проанализируем данные электронной таблицы до перемещения:

    • В ячейке C2 будет находиться число 4, так как функция СЧЁТ подсчитывает количество непустых ячеек указанного диапазона.
    • В ячейке С3 будет находиться число 3:
    • (1 + 2 + 2 + 6 + 4) / 5 = 3

      Теперь посмотрим, что произойдет после перемещения:

    • Перемещение содержимого ячейки означает, что ячейка B2 окажется пустой, а в ячейке B3 появится число 6.
    • Тогда расчёт формулы в ячейке C2 поменяется: количество непустых ячеек диапазона A1:B2 станет равным 3.
    • Соответственно изменится и значение после расчёта формулы ячейки C3: среднее значение содержимого диапазона ячеек A1:C2 станет равным:
    • (1 + 2 + 2 + 3) / 4 = 2

      (нужно не забывать, что функция СРЗНАЧ не учитывает пустые ячейки, поэтому ячейка B2 не учтена).

    • Таким образом, значение после перемещения формулы изменилось, уменьшившись на 1. Верный ответ 2

    Результат: 2

    Подробное решение задания на видео:


    Задание:

    В электронной таблице значение формулы =СРЗНАЧ(С2:С5) равно 3.

    Чему равно значение формулы =СУММ(С2:С4), если значение ячейки С5 равно 5?

    ✍ Решение:

    • Функция СРЗНАЧ предназначена для вычисления среднего арифметического значения указанного диапазона ячеек. Т.е. в нашем случае среднее значение ячеек C2, C3, C4, C5.
    • Результат функции =СРЗНАЧ(С2:С5) задан по условию, подставим его в формулу:
    • (C2 + C3 + C4 + C5)/4 = 3
    • Примем неизвестную сумму в за x и получим по формуле вычисления среднего значения:
    • x / 4 = 3
    • Найдем x:
    • x = 3 * 4 = 12  ->  C2 + C3 + C4 + C5 = 12
    • По заданию необходимо найти =СУММ(С2:С4). Зная значение в ячейке С5, вычтем его из полученной суммы и найдем ответ:
    • C2 + C3 + C4 = C2 + C3 + C4 + C5 - C5 = 
      = 12 - 5 = 7 

    Результат: 7

    Подробное решение смотрите на видео:



    Рассмотрим еще один пример решения 9 задания ЕГЭ по информатике:

    9_10: ЕГЭ по информатике 2017 задание 9 (7) ФИПИ вариант 15 (Крылов С.С., Чуркина Т.Е.):

    Дан фрагмент электронной таблицы:
    разбор 9 задания егэ по информатике

    Какое целое число должно быть записано в ячейке C1, чтобы построенная после выполнения вычислений диаграмма по значениям диапазона ячеек А2:С2 соответствовала рисунку?
    Известно, что все значения диапазона, по которым построена диаграмма, имеют один и тот же знак.

    ✍ Решение:

    • Круговая диаграмма отображает доли отдельных частей в общей сумме. В нашем случае в диаграмме отражаются результаты вычисления формул в ячейках А2:С2
    • По диаграмме можно судить о том, что, скорее всего, полученные значения в формулах во всех ячейках должны быть равны (секторы диаграммы визуально равны).
    • Получим выражения из формул ячеек, подставив вместо С1 -> x:
    • А2: х + 2
      В2: 8/2 = 4
      С2: х * 2
      
    • Так как секторы диаграммы равны, то приравняем два из полученных выражений (например, С2 = В2):
    • 2 * х = 4 => x = 2
      

    Результат: 2

    Детальный разбор можно посмотреть в видеоуроке решения данного 9 задания ЕГЭ по информатике:


    9_11: Пример задания с ege.yandex.ru

    Задан фрагмент электронной таблицы:
    1

    Какое число должно быть записано в ячейке B1, чтобы построенная после выполнения вычислений диаграмма по значениям диапазона ячеек A2:C2 соответствовала рисунку:
    2

    ✍ Решение:

    • По диаграмме можно судить только о следующем: если она не перевернута, то значения в ячейках A2 и B2 должны быть равны, а значение ячейки C2 — в два раза больше каждой из них.
    • Поскольку у нас неизвестны значения двух ячеек, то обозначим B1 за x, а C1 за y.
    • Подставим неизвестные в формулы и получим:
    • 1

    • Исходя из первого пункта, получаем:
    • A2 = B2 = C2/2
    • Составим систему уравнений:
    • 4y = x - y
      2 * 4y = x - y + 4
      
    • Первое уравнение нам дает x = 5y. Подставим это значение во второе уравнение:
    • 8y = 5y - y + 4  ->  y = 1
    • Таким образом, x=5. А значения ячеек A2 = B2 = 4, C2 = 8. Т.е. изображение диаграммы действительно сходится с полученными значениями.

    Результат: 5

    Подробное решение смотрите на видео:


    9_12: Задание № 10 (до 2020г), К. Поляков:

    Дан фрагмент электронной таблицы в режиме отображения формул:
    задание 9
    После копирования диапазона ячеек АЗ:ЕЗ в диапазон А4:Е6 была построена диаграмма (график) по значениям столбцов диапазона ячеек В2:Е6.
    1_11

    Значениям D2:D6 соответствует график:
     
    Варианты:
    1) А   2) Б   3) В   4) Г

    ✍ Решение:

    • Копирование диапазона ячеек АЗ:ЕЗ в диапазон А4:Е6 буквально означает выделение диапазона АЗ:ЕЗ и протягивание маркера копирования до конца указанного блока ячеек.
    • Поскольку нас интересует только столбец D, то посмотрим, что там за формула, и что с ней произойдет при копировании:
    • 1

    • в ячейке D3 значение зависит от ячейки A3 и оно равно 2;
    • при копировании формулы столбец остается тот же (D), поэтому и в формуле буквы остаются теми же (D и A), а вот строки копируются вниз, т.е. цифры в формуле увеличиваются на единицу при движении вниз на каждую строку; соответственно, нас интересуют еще ячейки A4, A5, A6;
    • формулы ячеек A4, A5, A6 зависят от ячеек столбца B, поэтому рассмотрим получившиеся при копировании формулы столбцов A и B:
    • 1_11

    • Теперь вычислим значения в этих столбцах:
    • 2

    • Получаем точки по столбцу D: 1, -1, -1, -7, -15, что соответствует графику Г (ответ 4)

    Результат: 4

    Разбор задания смотрите на видео:


    9_13: Задание № 83 (до 2020 г), Поляков К.:

    Дан фрагмент электронной таблицы:
    1
    1
    Какое целое число должно быть записано в ячейке C1, чтобы построенная после выполнения вычислений диаграмма по значениям диапазона ячеек A2:D2 соответствовала рисунку? Известно, что все значения диапазона, по которым построена диаграмма, положительные.

    ✍ Решение задания 7:

    • На изображенной диаграмме (если она преднамеренно не перевернута) секторы соответствуют указанному диапазону ячеек при движении по часовой стрелке с «севера на юг»: т.е. А2 — синий сектор, B2 — красный и т.п. Таким образом, делаем следующий вывод:
    • А2 = B2 = 2 * C2 = 2 * D2
    • Поскольку необходимо найти C1, и оно встречается в формулах, то примем его за x.
    • Перепишем формулы согласно введенному обозначению:
    • 1_11

    • Приравняем формулы в ячейках B2 и D2 (см. п.1) и получим:
    • B2 = 2 * D2
      2(x + 5) = x + 21
      2x - x = 21 - 10
      x = 11
      
    • Т.е. С1 = 11

    Результат: 11

    Видеоразбор задания:


    3 комментария

      Александр

      В первых заданиях файлы для скачивания одинаковые, начиная со второго и до последнего с файлом, скачивает файл с предупреждением о том что уже был скачен, ну и открываешь, а там файл из 2 задания

      Людмила

      В заданиях после первого при открытии файла электронной таблицы скачивается файл, не имеющий отношения к заданию. Где найти файл «9-0.xls (в заголовке задания»?

        admin

        Ребят, там на самом деле один и тот же файл; его не нужно скачивать несколько раз

    Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *

    *
    *


    Вставить формулу как
    Блок
    Строка
    Дополнительные настройки
    Цвет формулы
    Цвет текста
    #333333
    Используйте LaTeX для набора формулы
    Предпросмотр
    \({}\)
    Формула не набрана
    Вставить