Тренировка 6 задания ОГЭ по информатике (6.4) про исполнителя Черепашку

Разбор задания 6.1:

Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует две команды:

  • Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движения;
  • Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.
  • Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.
  •   
    Черепашке был дан для исполнения следующий алгоритм:

    Повтори 7 [Вперёд 70 Направо 120]
    

    Какая фигура появится на экране?

    1) правильный шестиугольник
    2) незамкнутая ломаная линия
    3) правильный семиугольник
    4) правильный треугольник

    ✍ Решение:
     

    • Вспомним формулу для вычисления количества вершин многоугольника по внешнему углу:
    • n = 360 / y
      
      где y - значение внешнего угла
      
    • Подставим значение для внешнего угла:
    • n = 360 / 120
      n = 3
      
    • Таким образом, Черепашка нарисует правильный треугольник, а за следующие четыре шага пройдет по трём его сторонам ещё раз. Верный ответ соответствует варианту 4.

    Ответ: 4


    Разбор задания 6.2:

    Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

    У исполнителя существует две команды:

  • Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движения;
  • Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.
  • Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.
  •   
    Черепашке был дан для исполнения следующий алгоритм:

    Повтори 5 [Вперёд 80 Направо 60]
    

    Какая фигура появится на экране?

    1) правильный пятиугольник
    2) правильный треугольник
    3) правильный шестиугольник
    4) незамкнутая ломаная линия

    ✍ Решение:
     

    Ответ: 4


    Разбор задания 6.3:

    Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

    У исполнителя существует две команды:

  • Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движения;
  • Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.
  • Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз.
  •   
    Черепашке был дан для исполнения следующий алгоритм:

    Повтори 12 [Направо 45 Вперёд 20 Направо 45]
    

    Какая фигура появится на экране?

    1) квадрат
    2) правильный двенадцатиугольник
    3) правильный восьмиугольник
    4) незамкнутая ломаная линия

    ✍ Решение:
     

    Ответ: 1


    Поделитесь уроком с коллегами и друзьями:

    Добавить комментарий

    Ваш e-mail не будет опубликован. Обязательные поля помечены *

    *
    *


    Вставить формулу как
    Блок
    Строка
    Дополнительные настройки
    Цвет формулы
    Цвет текста
    #333333
    Используйте LaTeX для набора формулы
    Предпросмотр
    \({}\)
    Формула не набрана
    Вставить