Задание 20.1 ОГЭ информатика по теме «Короткий алгоритм в среде формального исполнителя»

На уроке рассмотрен материал для подготовки к ОГЭ (ГИА) по информатике, разбор 20 задания. Объясняется тема об осуществлении алгоритма в среде формального исполнителя, робота.

Объяснение и разбор задания 20 ОГЭ информатика

Разбор задания 20.1:

Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды — это команды-приказы:

вверх 
вниз 
влево 
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно:

  • вверх ↑
  • вниз ↓
  • влево ←
  • вправо →
  • Если Робот получит команду передвижения сквозь стену, то он разрушится. Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.
    Ещё четыре команды — это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

    сверху свободно 
    снизу свободно 
    слева свободно 
    справа свободно
    

    Эти команды можно использовать вместе с условием «если», имеющим следующий вид:

    если условие то
     последовательность команд
    все
    

    Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов.

    Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:
    если справа свободно то
    вправо
    закрасить
    все
    

    В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

    если (справа свободно) и (не снизу свободно) то
     вправо
    все
    

    Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

    нц пока условие
       последовательность команд
    кц
    

    Где кц — конец цикла, нц — начало цикла.

    Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:
    нц пока справа свободно
      вправо
    кц
    

      
    Выполните задание:
    На бесконечном поле есть горизонтальная и вертикальная стены. Правый конец горизонтальной стены соединён с нижним концом вертикальной стены. Длины стен неизвестны. В вертикальной стене есть ровно один проход, точное место прохода и его ширина неизвестны. Робот находится в клетке, расположенной непосредственно под горизонтальной стеной у её левого конца.
    На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

  • Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно правее вертикальной стены.
  • Проход должен остаться незакрашенными.
  • Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).
  • При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться.
  • Конечное расположение Робота может быть произвольным.
  • Алгоритм должен решать задачу для любого допустимого расположения стен и любого расположения и размера прохода внутри стены.
  • Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе. Сохраните алгоритм в текстовом файле.


    ✍ Решение:
     

      Возможны другие варианты алгоритма для робота:

    • Комментарии будем обозначать красным цветом:
    • Двигаемся вправо, пока не дойдем до края стены.
      нц пока не сверху свободно
        вправо
      кц
      Шаг вверх.
      вверх
      Двигаемся вверх, пока не дойдем до края стены, закрашивая клетки.
      нц пока не слева свободно
        закрасить
        вверх
      кц
      Двигаемся вверх, пока не дойдем до стены (слева).
      нц пока слева свободно
        вверх
      кц
      Двигаемся вверх, пока не дойдем до края стены, закрашивая клетки.
      нц пока не слева свободно
        закрасить
        вверх
      кц
      
    Поделитесь уроком с коллегами и друзьями:

    Добавить комментарий

    Ваш e-mail не будет опубликован. Обязательные поля помечены *

    *
    *


    Вставить формулу как
    Блок
    Строка
    Дополнительные настройки
    Цвет формулы
    Цвет текста
    #333333
    Используйте LaTeX для набора формулы
    Предпросмотр
    \({}\)
    Формула не набрана
    Вставить